16 mayo 2012

Problema con el cambio de WASADMIN y PORTALADMIN en Portal 7.0.0.2

Hoy me encontré con este problema mientras intentaba cambiar los usuarios de administración del WAS y del Portal (7002):

[wplc-validate-user-exists]   Instance attributes (Set 1 of 1):
[wplc-validate-user-exists]     ignoreDuplicateIDs= *** NOT_SPECIFIED ***
[wplc-validate-user-exists]     attribute=[ *** NONE_SPECIFIED *** ]
[wplc-validate-user-exists]     customproperty=[ *** NONE_SPECIFIED *** ]
[wplc-validate-user-exists]     cn="CN=wasadmin,OU=usuarios,OU=portal,DC=pe,DC=ibm,DC=com"
[wplc-validate-user-exists]     trimSpaces= *** NOT_SPECIFIED ***
[wplc-validate-user-exists] com.ibm.websphere.management.cmdframework.InvalidParameterNameException: ADMF0004E: Invalid parameter name CN for command searchUsers.
[wplc-validate-user-exists]     at com.ibm.websphere.management.cmdframework.provider.AbstractAdminCommand.getParameterMetadata(AbstractAdminCommand.java:1096)
[wplc-validate-user-exists]     at com.ibm.websphere.management.cmdframework.provider.AbstractAdminCommand.isParamReadonly(AbstractAdminCommand.java:1162)
[wplc-validate-user-exists]     at com.ibm.websphere.management.cmdframework.provider

Gracias al post de Dave Hay pude encontrar la solución (bueno, un workaround), agregarle "-Dskip.ldap.validation=true" al final de la sentencia.

Sentencia para el cambio de usuario administrador del WAS:

./ConfigEngine.sh wp-change-was-admin-user -DWasPassword=wpadmin -DnewAdminId=CN=wasadmin,OU=usuarios,OU=portal,DC=pe,DC=ibm,DC=com -DnewAdminPw=wasadmin -Dskip.ldap.validation=true


Sentencia para el cambio de usuario administrador del Portal:


./ConfigEngine.sh wp-change-portal-admin-user -DWasPassword=wasadmin -DnewAdminId=CN=wpsadmin,OU=usuarios,OU=portal,DC=pe,DC=ibm,DC=com -DnewAdminPw=wpsadmin -DnewAdminGroupId=CN=wpadmins,OU=grupos,OU=portal,DC=pe,DC=ibm,DC=com -Dskip.ldap.validation=true
Publicar un comentario